View unanswered posts | View active topics It is currently Sat Oct 25, 2014 5:13 am



Reply to topic  [ 1 post ] 
 WII_LaunchTitle disables video output 
Author Message

Joined: Fri Apr 27, 2012 6:05 am
Posts: 12
Location: The Twilight Zone
I only just noticed this. In the past I could just use WII_LaunchTitle in a list, then give a message if none of the titles existed. For example, if you wanted to give a choice between loading the HBC and reseting, you could do something like:
Code:
while(1) {
      WPAD_ScanPads();
      u32 p = WPAD_ButtonsDown(0);
      if (p & WPAD_BUTTON_A) {
         WII_LaunchTitle(TITLE_ID(0x00010001,0xAF1BF516)); // HBC v1.0.7+
         WII_LaunchTitle(TITLE_ID(0x00010001,0x4a4f4449)); // HBC JODI
         WII_LaunchTitle(TITLE_ID(0x00010001,0x48415858)); // HBC HAXX
         printf("\rHBC is not installed");
         sleep(2);
      }
      if (p & WPAD_BUTTON_HOME) SYS_ResetSystem(SYS_RESTART,0,0); // Restart Wii
      VIDEO_WaitVSync();
   }


Now, "HBC is not installed" won't be shown because video output is disabled. When using the pointer to select options, that makes things far worse because then you can't see what other options are available. In the meantime, I've added VIDEO_SetBlack(false); before messages, but the screen still flashes off for a split second.


Thu Jun 07, 2012 2:29 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
  Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.
Get devkitPro at SourceForge.net. Fast, secure and Free Open Source software downloads