View unanswered posts | View active topics It is currently Thu Sep 18, 2014 6:42 pm



Reply to topic  [ 5 posts ] 
 [Solved] Problems using "HomebrewMenu" 
Author Message

Joined: Sun Mar 29, 2009 9:23 pm
Posts: 29
I want to use NitroFS in my current project, however my hardware [M3 DS Real + M3Sakura V1.35 USA/Europe]
does not support the "argv"-Stuff needed by NitroFS. I have downloaded and modified the HomebrewMenu mentioned
in http://forums.devkitpro.org/viewtopic.php?p=2607#p2607 to directly launch another NDS file by setting
Code:
const char DEFAULT_FILE[] = "Test.nds";


Test.nds as well as the launcher is stored in the Root folder of the SD card an contains the program
(based on \examples\nds\filesystem\nitrofs\nitrodir)
Code:
#include <nds.h>
#include <filesystem.h>
#include <stdio.h>

/******************************************************************************/
int main(int argc, char **argv)
/******************************************************************************/
{
  consoleDemoInit();
 
  while(1)
  {
    touchPosition P;
    consoleClear();
   
    printf("argv[0] = %s\n", argv[0]);
 
    scanKeys();
    touchRead(&P);
    printf("KeysHeld = %i\n", keysHeld());
    printf("Touch    = %i, %i", P.px, P.py);

    swiWaitForVBlank();
  }
  return 0;
}


If I run Test.nds on no$gba 2.6 or hardware (w/o HomebrewMenu) everything works fine:
Code:
argv[0] = (null)
KeysHeld = 0
Touch    = 0,0

with values changing according to input.

When I launch the same file using HomebrewMenu, argv is set correctly but the keys X,Y and Touchscreen are not working.
Also KeysHeld gives the value 8192 if no key is pressed. All working keys are "or'ed" to 8192. Touch remains 0,0.
Code:
argv[0] = fat:/test.nds
KeysHeld = 8192
Touch    = 0,0


My current installation of devktiPro is: (installed.ini)
Code:
[mirror]
url=

[msys]
Version=1.0.11-RC2

[devkitARM]
Version=26

[devkitPPC]
Version=0

[devkitPSP]
Version=0

[libgba]
Version=20090222

[libnds]
Version=1.3.5

[libmirko]
Version=0.9.7

[pnotepad]
Version=0

[insight]
Version=0

[ndsexamples]
Version=20090531

[gbaexamples]
Version=20090222

[cubeexamples]
Version=0

[pspdoc]
Version=0
[libgbafat]
Version=1.0.4
[libndsfat]
Version=1.0.4
[defaultarm7]
Version=0.5.4
[dswifi]
Version=0.3.9
[filesystem]
Version=0.9.2
[maxmodds]
Version=1.0.5


Any idea what's going wrong here?


Last edited by RyouArashi on Fri Jun 26, 2009 10:06 pm, edited 1 time in total.



Fri Jun 19, 2009 12:12 pm
Profile

Joined: Sun Feb 22, 2009 7:59 pm
Posts: 133
I just ran your test code on a DSi using EzFlash Vi cart - using my HomebrewMenu (which is the one you download, without the change you made) + fix (#include <stdio.h> to fix the iprintf issue) I get the same results as you.

Running your code on desmume and your code acts just like on hardware.

Mind you I did change the output for the buttons to be %04x (to give me an idea of what buttons are being pressed) and I could get every button to work apart from X / Y buttons.

I know that I'm experiencing some minor issues on my DSi with the EzFlash Vi - I can't use colors! any more as there is no pressure detected, yet the new Brain Training DSiWare app looks like it's using pressure on my name (it might just be faking it as well). As for why this issue is not working, I'm not sure, it does seem a little strange, as looking at the number for the touch button (8192) the system seems to think that you have the Y button held down constantly...

I even added the nitrofs init code, just in case that has something to do with it - same thing happens...

I think this is one for WinterMute or dovoto...


Sat Jun 20, 2009 2:45 pm
Profile

Joined: Sun Mar 29, 2009 9:23 pm
Posts: 29
Thanks for testing. I was also thinking about something being wrong with my installation...

I suspect that theres something wrong on the ARM7 side, e.g. it the ARM7 binary
not being loaded properly or being out of sync or something... But I have no idea how
to check or fix this...


Mon Jun 22, 2009 9:38 am
Profile
Site Admin

Joined: Tue Aug 09, 2005 3:21 am
Posts: 1135
Location: UK
Try again with the latest libnds & default arm7 releases. There was also an extra delay in the Homebrew menu boot code which has been removed in SVN.

_________________
devkitPro IRC support
Personal Blog


Wed Jun 24, 2009 2:53 pm
Profile ICQ WWW

Joined: Sun Mar 29, 2009 9:23 pm
Posts: 29
Updated to latest libnds and arm7 and redownloaded HomebrewMenu, recompiled and everything works fine : -)


Fri Jun 26, 2009 1:50 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
  Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.
Get devkitPro at SourceForge.net. Fast, secure and Free Open Source software downloads