Search found 18 matches

by JoostinOnline
Tue Jun 26, 2012 3:16 am
Forum: Gamecube/Wii Development
Topic: Please fix launching titles with arguments
Replies: 12
Views: 11754

Re: Please fix launching titles with arguments

I've noticed another problem that I assumed was fixed along with libogc 1.8.11, but I guess not. WII_ReturnToSettings() goes to Data Management.

Why don't you just remove both Daco's patches? I don't know what the first was supposed to do, but everything was working fine prior to that.
by JoostinOnline
Thu Jun 07, 2012 2:29 am
Forum: Bug Reports
Topic: WII_LaunchTitle disables video output
Replies: 0
Views: 4288

WII_LaunchTitle disables video output

I only just noticed this. In the past I could just use WII_LaunchTitle in a list, then give a message if none of the titles existed. For example, if you wanted to give a choice between loading the HBC and reseting, you could do something like: while(1) { WPAD_ScanPads(); u32 p = WPAD_ButtonsDown(0);...
by JoostinOnline
Tue May 01, 2012 1:36 am
Forum: Gamecube/Wii Development
Topic: Please fix launching titles with arguments
Replies: 12
Views: 11754

Re: Please fix launching titles with arguments

Actually they are. I didn't know I wasn't supposed to. I started doing this just to screw around, I never thought I would end up actually making apps worth distributing. I've never even learned C, I'm just basing everything on what other languages I know. Since this last release will almost certainl...
by JoostinOnline
Mon Apr 30, 2012 10:12 pm
Forum: Gamecube/Wii Development
Topic: Please fix launching titles with arguments
Replies: 12
Views: 11754

Re: Please fix launching titles with arguments

It tells Priiloader to ignore the current autoboot/return to settings and load the System Menu instead. Priiloader will interfere with WII_ReturnToSettingsPage(SETTINGS_INTERNET) if they both aren't set to System Menu, so I use magic word (that's the name of the code) to force loading the SM if nece...
by JoostinOnline
Mon Apr 30, 2012 4:10 pm
Forum: Gamecube/Wii Development
Topic: Please fix launching titles with arguments
Replies: 12
Views: 11754

Re: Please fix launching titles with arguments

It wasn't part of the changeset fpr 1.8.11, that's merely the most recent release. As it happens it was part of the changeset from 1.8.9 to 1.8.10 which I never got around to doing a release announcement for. The entire history is exactly where you'd expect it to be ... The important question here ...
by JoostinOnline
Sun Apr 29, 2012 8:09 pm
Forum: Gamecube/Wii Development
Topic: Please fix launching titles with arguments
Replies: 12
Views: 11754

Re: Please fix launching titles with arguments

I see no mention of it in the changelog. Is there a place I can look at the entire history for each release?
by JoostinOnline
Sun Apr 29, 2012 12:38 am
Forum: Gamecube/Wii Development
Topic: Please fix launching titles with arguments
Replies: 12
Views: 11754

Re: Please fix launching titles with arguments

A patch has already been submitted by DacoTaco, whose original patch broke wiilaunch. I've just been removing the changes made in 1.8.7 (which I don't like doing, as I don't know how it might affect everything else), so I can't confirm if it works, only that the pre-compiled libogc doesn't. I'll try...
by JoostinOnline
Fri Apr 27, 2012 6:14 am
Forum: Gamecube/Wii Development
Topic: Please fix launching titles with arguments
Replies: 12
Views: 11754

Please fix launching titles with arguments

WII_LaunchTitleWithArgs has been broken since v1.8.7, and I've had to compile my own version each time. I would really appreciate it if you would fix it.