ndstool: Not working properly on Mac OS X 10.5 PPC

Post Reply
Marvose
Posts: 3
Joined: Sun Oct 19, 2008 1:48 am

ndstool: Not working properly on Mac OS X 10.5 PPC

Post by Marvose » Sun Oct 19, 2008 2:08 am

1.42 GHz PPC Mac mini
Mac OS X 10.5.5

I just successfully built and installed devkitARM using the buildtools. I'm experiencing problems extracting the following components using ndstool:

ARM7 executable: the process never ends; it generates a file that never stops growing. It got to about 5 gigs before I interrupted it.
ARM9 executable: same as ARM7.
ARM7 overlay table: generates an empty file.
ARM9 overlay table: same as ARM7.
Data files: seems to work properly.
Overlay files: generates an empty directory.
Banner bitmap: generates a non-empty (2,012 bytes) file that does not appear to be a valid bitmap; I can't open it in Preview or Photoshop.
Logo bitmap: same as banner.

Attempting to read the ARM7/ARM9 RAM addresses or entries results in:

Code: Select all

Bus error
The syntax I'm using is as follows:

Code: Select all

ndstool -x foo.nds -9 foo.bin
Please let me know if there's any more information you need, or any more tests I can perform on my end.

EDIT: Just tried the pre-compiled ndstool from devkitARM release 21, the last release compiled for PPC OS X. Same problems. Starting to drive me batty, as I seem to be the only one to whom this is happening.

EDIT2: Just tried it on a friend's Intel Mac. Everything seemed to work fine.

EDIT3: And now I've tried it on another friend's PPC Mac. Same problems as mine. Endianness?

WinterMute
Site Admin
Posts: 1404
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: ndstool: Not working properly on Mac OS X 10.5 PPC

Post by WinterMute » Wed Oct 29, 2008 10:08 am

Definitely looks like an endianness problem on the extraction functions.

I've recently obtained a macbook for working with the OSX toolchain builds so I'll have a look at this for the next devkitARM release.
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

Marvose
Posts: 3
Joined: Sun Oct 19, 2008 1:48 am

Re: ndstool: Not working properly on Mac OS X 10.5 PPC

Post by Marvose » Wed Oct 29, 2008 9:48 pm

Thanks! I eagerly await the next release.

Marvose
Posts: 3
Joined: Sun Oct 19, 2008 1:48 am

Re: ndstool: Not working properly on Mac OS X 10.5 PPC

Post by Marvose » Fri Feb 20, 2009 1:28 am

Hello again.

I just tested the latest release and encountered a problem with overlay files. Here's my terminal output:

Code: Select all

$ ndstool -v -x ./*.nds -y ./overlay
Nintendo DS rom tool 1.40 - Nov 23 2008
by Rafael Vuijk, Dave Murphy, Alexei Karpenko
    0 0x00073200 0x00082630     62512 /overlay_0000.bin
16777216 0x00000000 0x00082630    534064 /overlay_16777216.bin
33554432 0x00000000 0x00082630    534064 /overlay_33554432.bin
50331648 0x00000000 0x00082630    534064 /overlay_50331648.bin
67108864 0x00000000 0x00082630    534064 /overlay_67108864.bin
83886080 0x00000000 0x00082630    534064 /overlay_83886080.bin
100663296 0x00000000 0x00082630    534064 /overlay_100663296.bin
117440512 0x00000000 0x00082630    534064 /overlay_117440512.bin
134217728 0x00000000 0x00082630    534064 /overlay_134217728.bin
150994944 0x00000000 0x00082630    534064 /overlay_150994944.bin
167772160 0x00000000 0x00082630    534064 /overlay_167772160.bin
184549376 0x00000000 0x00082630    534064 /overlay_184549376.bin
201326592 0x00000000 0x00082630    534064 /overlay_201326592.bin
218103808 0x00000000 0x00082630    534064 /overlay_218103808.bin
234881024 0x00000000 0x00082630    534064 /overlay_234881024.bin
251658240 0x00000000 0x00082630    534064 /overlay_251658240.bin
268435456 0x00000011 0x02128060  34766927 /overlay_268435456.bin
285212672 0x00000012 0x0216F200  35058158 /overlay_285212672.bin
301989888 0x00000013 0x0216F200  35058157 /overlay_301989888.bin
318767104 0x00000014 0x0216F200  35058156 /overlay_318767104.bin
335544320 0x00000015 0x02186960  35154251 /overlay_335544320.bin
352321536 0x00000016 0x02186960  35154250 /overlay_352321536.bin
369098752 0x00000017 0x02186980  35154281 /overlay_369098752.bin
385875968 0x00000018 0x02186980  35154280 /overlay_385875968.bin
402653184 0x00000019 0x02186980  35154279 /overlay_402653184.bin
419430400 0x0000001A 0x02186980  35154278 /overlay_419430400.bin
436207616 0x0000001B 0x02186980  35154277 /overlay_436207616.bin
452984832 0x0000001C 0x02186980  35154276 /overlay_452984832.bin
469762048 0x0000001D 0x02186980  35154275 /overlay_469762048.bin
486539264 0x0000001E 0x02186980  35154274 /overlay_486539264.bin
503316480 0x0000001F 0x02186980  35154273 /overlay_503316480.bin
520093696 0x00000020 0x02186980  35154272 /overlay_520093696.bin
536870912 0x00073200 0x00082630     62512 /overlay_536870912.bin
553648128 0x00000000 0x00082630    534064 /overlay_553648128.bin
570425344 0x00000000 0x00082630    534064 /overlay_570425344.bin
587202560 0x00000000 0x00082630    534064 /overlay_587202560.bin
603979776 0x00000000 0x00082630    534064 /overlay_603979776.bin
620756992 0x00000000 0x00082630    534064 /overlay_620756992.bin
637534208 0x00000000 0x00082630    534064 /overlay_637534208.bin
654311424 0x00000000 0x00082630    534064 /overlay_654311424.bin
671088640 0x00000000 0x00082630    534064 /overlay_671088640.bin
687865856 0x00000000 0x00082630    534064 /overlay_687865856.bin
704643072 0x00000000 0x00082630    534064 /overlay_704643072.bin
721420288 0x00000000 0x00082630    534064 /overlay_721420288.bin
As you can see, the filenames are all wrong after overlay_0000.bin, and several of the files are crazy huge; 16 of them are over 30 MB (the original file I extracted them from was 128 MB; the overlay folder alone is over 500 MB)

Any ideas?

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests