devkitPPC dependency issues

Post Reply
Rena
Posts: 12
Joined: Sun Sep 23, 2012 2:36 pm

devkitPPC dependency issues

Post by Rena » Sun Sep 23, 2012 2:44 pm

Following the instructions on the Getting Started wiki page, I had to compile devkitPPC (on the Wii itself, no less), and ran into a couple dependency issues.

First of all, I was told gxtexconv couldn't be compiled because I was missing libfreeimage, which I wasn't. In reality it was libstdc++ dev files it wanted.

Then I also had to install OpenGL dev files, which also wasn't mentioned as a dependency anywhere causing a compile failure.

Finally, it told me to add a line to my environment:
DEVKITPRO=/opt/devkitpro DEVKITPPC=/opt/devkitpro/devkitPPC

This is a bit misleading, because 1) it's missing a line break and 2) it's missing "export". What I really needed to add was:
export DEVKITPRO=/opt/devkitpro
export DEVKITPPC=/opt/devkitpro/devkitPPC

After that I was able to successfully compile and execute devkitPPC. Now if only it worked:

Code: Select all

whiite:/opt/devkitpro/examples/wii# make
make[1]: Entering directory `/opt/devkitpro/examples/wii/audio'
make[2]: Entering directory `/opt/devkitpro/examples/wii/audio/modplay'
linking ... modplay.elf
/opt/devkitpro/devkitPPC/lib/gcc/powerpc-eabi/4.6.3/../../../../powerpc-eabi/bin/ld: cannot find -lwiiuse
/opt/devkitpro/devkitPPC/lib/gcc/powerpc-eabi/4.6.3/../../../../powerpc-eabi/bin/ld: cannot find -lbte
/opt/devkitpro/devkitPPC/lib/gcc/powerpc-eabi/4.6.3/../../../../powerpc-eabi/bin/ld: cannot find -lmodplay
/opt/devkitpro/devkitPPC/lib/gcc/powerpc-eabi/4.6.3/../../../../powerpc-eabi/bin/ld: cannot find -laesnd
/opt/devkitpro/devkitPPC/lib/gcc/powerpc-eabi/4.6.3/../../../../powerpc-eabi/bin/ld: cannot find -logc
collect2: ld returned 1 exit status
make[3]: *** [/opt/devkitpro/examples/wii/audio/modplay/modplay.elf] Error 1
make[2]: *** [build] Error 2
make[2]: Leaving directory `/opt/devkitpro/examples/wii/audio/modplay'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/opt/devkitpro/examples/wii/audio'
make: *** [all] Error 1

mtheall
Posts: 210
Joined: Thu Feb 03, 2011 10:47 pm

Re: devkitPPC dependency issues

Post by mtheall » Sun Sep 23, 2012 3:09 pm

If you mean this Getting Started page, there are no instructions about compiling devkitPPC, only about installing. You should only be compiling devkitPPC if you plan on aiding in its development (that is, development of devkitPPC, not development of Wii/GC homebrew).

Rena
Posts: 12
Joined: Sun Sep 23, 2012 2:36 pm

Re: devkitPPC dependency issues

Post by Rena » Sun Sep 23, 2012 3:13 pm

Yes, that page. I'm running Linux on the Wii for lack of access to much else; there doesn't seem to be a precompiled tarball for PPC. (Irony?)

Also strange, probably related to the library issue:

$ file /opt/devkitpro/libogc/lib/wii
/opt/devkitpro/libogc/lib/wii: current ar archive

I would have expected a directory? If not, then where are lwiiuse, lbte etc supposed to be? Are they not part of libogc?

Rena
Posts: 12
Joined: Sun Sep 23, 2012 2:36 pm

Re: devkitPPC dependency issues

Post by Rena » Sun Sep 23, 2012 8:13 pm

As I suspected the libogc I got from the tarball was faulty and I had to compile it from
source.
After that, I still can't compile the examples, as oggplayer.c fails claiming it
can't find tremor/ivorbiscodec.h, despite it being right there in /usr/include, so I really
have no idea how even to fix that, or how it can be broken in the first place.
That file is part of package libvorbisidec-dev, another dependency not mentioned
anywhere.

Anyway, I'm not too interested in audio, so skipping that for now, the other examples are
compiling OK, except filesystem which failed because libfat.a was in the wrong place
(/opt/devkitpro/libfat-ogc/lib/wii/libfat.a instead of /opt/devkitpro/libogc/lib/wii/libfat.a),
but I don't remember, I might have put it there myself. After fixing that I tested a few of
the example programs and they work fine.

WinterMute
Site Admin
Posts: 1404
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: devkitPPC dependency issues

Post by WinterMute » Wed Oct 03, 2012 12:52 am

Sorry, there are no plans to support compiling devkitPPC (or any of our other toolchains) on the Wii. This is beyond silly.
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests