default-arm7-src-0.5.24.tar.bz2 404

Post Reply
Rena
Posts: 12
Joined: Sun Sep 23, 2012 2:36 pm

default-arm7-src-0.5.24.tar.bz2 404

Post by Rena » Sun Sep 23, 2012 9:58 pm

Uhoh, more buildscript issues:

Code: Select all

 $ ./build-devkit.sh
Please note, these scripts are provided as a courtesy, toolchains built with them
are for personal use only and may not be distributed by entities other than devkitPro.
See http://devkitpro.org/wiki/Trademarks

Patches and improvements are of course welcome, please send these to the patch tracker
https://sourceforge.net/tracker/?group_id=114505&atid=668553

Looking for configuration file... Found.

Please select the toolchain you require

1: devkitARM (gba gp32 ds)
2: devkitPPC (gamecube wii)
3: devkitPSP (PSP)
1
use /usr/bin/make as make
binutils-2.22.tar.bz2
gcc-4.7.1.tar.bz2
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 78.8M  100 78.8M    0     0   199k      0  0:06:44  0:06:44 --:--:--  220k
newlib-1.20.0.tar.gz
gdb-7.4.1.tar.bz2
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 19.6M  100 19.6M    0     0   264k      0  0:01:16  0:01:16 --:--:--  306k
libnds-src-1.5.7.tar.bz2
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  139k  100  139k    0     0  57914      0  0:00:02  0:00:02 --:--:--  153k
libgba-src-20090222.tar.bz2
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 55657  100 55657    0     0   5530      0  0:00:10  0:00:10 --:--:-- 12379
libmirko-src-0.9.7.tar.bz2
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  170k  100  170k    0     0   160k      0  0:00:01  0:00:01 --:--:--  160k
dswifi-src-0.3.13.tar.bz2
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 59621  100 59621    0     0  10651      0  0:00:05  0:00:05 --:--:-- 14559
maxmod-src-1.0.7.tar.bz2
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 74977  100 74977    0     0  78778      0 --:--:-- --:--:-- --:--:-- 78778
default-arm7-src-0.5.24.tar.bz2
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404
Error: Failed to download default-arm7-src-0.5.24.tar.bz2
I must be covered in honey for all the bugs I find.

Rena
Posts: 12
Joined: Sun Sep 23, 2012 2:36 pm

Re: default-arm7-src-0.5.24.tar.bz2 404

Post by Rena » Mon Sep 24, 2012 9:18 pm

Looks like in this case it's a simple typo:
default-arm7-src-0.5.24.tar.bz2 should be
default_arm7-src-0.5.24.tar.bz2

After manually downloading that (before noticing the name that I could have just fixed in the script) it spends about 16 hours(!) compiling before also telling me it needs libusb.

Rena
Posts: 12
Joined: Sun Sep 23, 2012 2:36 pm

Re: default-arm7-src-0.5.24.tar.bz2 404

Post by Rena » Mon Sep 24, 2012 9:36 pm

(hmm, no edit button on this forum?)

and then it stops again:
/root/code/wii/devkitppc/buildscripts/.devkitARM/default-arm7-0.5.24/source/main.c:32:21: fatal error: maxmod7.h: No such file or directory

Rena
Posts: 12
Joined: Sun Sep 23, 2012 2:36 pm

Re: default-arm7-src-0.5.24.tar.bz2 404

Post by Rena » Mon Sep 24, 2012 9:57 pm

...so after violently hacking the makefile to patch around that so I could move on to the next hurdle in the way of even beginning my project that doesn't even involve DS or audio...

/opt/devkitpro/devkitARM/lib/gcc/arm-none-eabi/4.7.1/../../../../arm-none-eabi/bin/ld: cannot find -lmm7

*facepalm*

Rena
Posts: 12
Joined: Sun Sep 23, 2012 2:36 pm

Re: default-arm7-src-0.5.24.tar.bz2 404

Post by Rena » Tue Sep 25, 2012 12:12 am

Sigh.

/root/code/wii/devkitppc/buildscripts/.devkitARM/libfat-1.0.11/gba/../include/fat.h:56:25: fatal error: disc_io.h: No such file or directory
compilation terminated.
make[2]: *** [cache.o] Error 1
make[1]: *** [release] Error 2
make[1]: Leaving directory `/root/code/wii/devkitppc/buildscripts/.devkitARM/libfat-1.0.11/gba'
make: *** [gba-release] Error 2
error installing gba libfat

libfat/gba/makefile has a suspicious duplicate line:
export INCLUDE := $(foreach dir,$(INCLUDES),-I$(CURDIR)/$(dir)) \
$(foreach dir,$(LIBDIRS),-I$(dir)/include) \
$(foreach dir,$(LIBDIRS),-I$(dir)/include) \
-I$(CURDIR)/$(BUILD)

The entire command line expands to:
arm-none-eabi-gcc -MMD -MP -MF /root/code/wii/devkitppc/buildscripts/.devkitARM/libfat-1.0.11/gba/release/cache.d -g -Wall -O2 -mcpu=arm7tdmi -mtune=arm7tdmi -fomit-frame-pointer -ffast-math -mthumb -mthumb-interwork -I/root/code/wii/devkitppc/buildscripts/.devkitARM/libfat-1.0.11/gba/../include -I/opt/devkitpro/libgba/include -I/opt/devkitpro/libgba/include -I/root/code/wii/devkitppc/buildscripts/.devkitARM/libfat-1.0.11/gba/release -DGBA -c /root/code/wii/devkitppc/buildscripts/.devkitARM/libfat-1.0.11/gba/../source/cache.c -o cache.o

Notice twice -I/opt/devkitpro/libgba/include, which is also suspcious since that directory doesn't even exist yet, since we're trying to build this already. A dependency on itself? Never seen that before.

So another quick dirty hack to fix that, and then:
/usr/bin/make -C gba install
make[1]: Entering directory `/root/code/wii/devkitppc/buildscripts/.devkitARM/libfat-1.0.11/gba'
cp: cannot create regular file `/opt/devkitpro/libgba/lib': No such file or directory

Apparently I have to manually create that and /opt/devkitpro/libgba/lib/include directories.

Finally, maxmod.mak tries to use arm-eabi-strip instead of arm-none-eabi-strip.

After fixing all of that, finally devkitARM compiles and installs successfully... now for food, then to see if it works.

Oh yeah, another little thing that's been annoying me, it keeps asking which devkit I want to build, even though I already wrote that in config.sh:
#---------------------------------------------------------------------------------
# Select package
#---------------------------------------------------------------------------------
# 0: User selects manually
# 1: devkitARM
# 2: devkitPPC
# 3: devkitPSP
#---------------------------------------------------------------------------------
BUILD_DKPRO_PACKAGE=2

(btw, I haven't been posting the "fixes" I've used because they're awful hacks involving absolute paths that will almost certainly not work for anyone else, likely even for me in the future, and probably cause more problems later.)

Rena
Posts: 12
Joined: Sun Sep 23, 2012 2:36 pm

Re: default-arm7-src-0.5.24.tar.bz2 404

Post by Rena » Tue Sep 25, 2012 3:50 am

Surprise.

The audio example fails to build because of not finding lmm (another maxmod issue), and the biosdumper example fails because of missing -lfat (just like with libogc). Also, libgba was broken (/opt/devkitpro/libgba/lib was a file instead of a directory, just like with libogc) and had to be replaced with the latest version from SourceForge. Seeing a pattern here!

After that, the examples build; now I just need to find a way to run them and I may finally be able to actually begin my project! (Well, the examples I can try in VBA at least, but that won't be available for the project.)

I should probably mention that I do appreciate all the work put into this software. I just hope you appreciate all the frustration put into making it work... >.> seem to have found a few fatal bugs.

(huh, this post has an edit button, but others don't!)

mtheall
Posts: 210
Joined: Thu Feb 03, 2011 10:47 pm

Re: default-arm7-src-0.5.24.tar.bz2 404

Post by mtheall » Wed Sep 26, 2012 8:52 pm

I fixed a bunch of this crap, thanks to your findings. Currently, maxmod will fail, but WinterMute will be fixing that soon. After that, the buildscripts should work no problem, assuming you have all the prereqs (I added libusb to the README)

http://devkitpro.git.sourceforge.net/gi ... 04db640291

Rena
Posts: 12
Joined: Sun Sep 23, 2012 2:36 pm

Re: default-arm7-src-0.5.24.tar.bz2 404

Post by Rena » Thu Sep 27, 2012 1:30 pm

Excellent. Glad my ranting was helpful. :p

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 3 guests