buildscripts-20080308 is broken

Post Reply
bsder
Posts: 11
Joined: Sun Mar 23, 2008 1:59 pm

buildscripts-20080308 is broken

Post by bsder » Sun Mar 23, 2008 2:02 pm

Running it on CentOS 5.1, I wind up with HAVE_INITFINI_ARRAY not being defined. I thought this got fixed at some point ...

I have filed a bug report on SF as well.

bsder
Posts: 11
Joined: Sun Mar 23, 2008 1:59 pm

Re: buildscripts-20080308 is broken

Post by bsder » Mon Mar 24, 2008 1:24 am

Once I manage to get that working, I then bump into another issue when I attempt to compile the examples:

/opt/devkitpro/libnds/lib/libnds9.a(initSystem.o): In function `initSystem':
/home/andrewl/dkp/buildscripts/libnds-20071023/source/arm9/initSystem.c:88: undefined reference to `punixTime'
collect2: ld returned 1 exit status
make[4]: *** [/home/andrewl/nds/examples/nds/card/eeprom/eeprom.elf] Error 1
make[3]: *** [build] Error 2
make[3]: Leaving directory `/home/andrewl/nds/examples/nds/card/eeprom'
make[2]: *** [all] Error 1
make[2]: Leaving directory `/home/andrewl/nds/examples/nds/card'
make[1]: *** [examples] Error 1
make[1]: Leaving directory `/home/andrewl/nds/examples/nds'
make: *** [all] Error 1

WinterMute
Site Admin
Posts: 1478
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: buildscripts-20080308 is broken

Post by WinterMute » Mon Mar 24, 2008 5:04 am

The HAVE_INITFINI_ARRAY thing is a newlib problem, it can't be built with make 3.81. I usually build with a local make 3.80 added temporarily to the path while building devkitARM.

I may have messed up the packaging of the buildscripts for devkitARM as well, sorry. I'm hoping to release devkitARM r22 very, very soon though so I'd rather update the scripts then rather than attempt to sort out something that will build r21 before then.
Help keep devkitPro toolchains free, Donate today

Personal Blog

bsder
Posts: 11
Joined: Sun Mar 23, 2008 1:59 pm

Re: buildscripts-20080308 is broken

Post by bsder » Tue Apr 01, 2008 11:19 am

WinterMute wrote:The HAVE_INITFINI_ARRAY thing is a newlib problem, it can't be built with make 3.81. I usually build with a local make 3.80 added temporarily to the path while building devkitARM.

I may have messed up the packaging of the buildscripts for devkitARM as well, sorry. I'm hoping to release devkitARM r22 very, very soon though so I'd rather update the scripts then rather than attempt to sort out something that will build r21 before then.
Ah, that would be a good tip to know. Can that get posted somewhere that Google will archive?

I can wait for r22. I just wanted to give this a shot before that. I really like to be able to build the system from source code so that if I need to debug something, I can go in and muck with it.

Also, I tend to run my own scripts with scons for building NDS stuff. I *really* hate magic in my build system. I like to know explicitly what the build system is doing so that when something goes wrong, I can start isolating faults. To do that, I had to pull things apart and create some of my own linkerscript files. This pretty much requires that I build from source.

Thanks for doing all the work on devkitPro.

theoxylo
Posts: 1
Joined: Wed Apr 02, 2008 9:23 pm

Re: buildscripts-20080308 is broken

Post by theoxylo » Wed Apr 02, 2008 9:28 pm

I too am having trouble at link time after building devkitpro from source (using build-devkit.sh). Here is the output:

linking TouchTest.elf
/home/toneill/nds/devkitpro/libnds/lib/libnds9.a(initSystem.o): In function `initSystem':
/home/toneill/nds/buildscripts/libnds-20071023/source/arm9/initSystem.c:88: undefined reference to `punixTime'
collect2: ld returned 1 exit status

Any good workaround? Thanks. And keep up the good work!

n8gray
Posts: 5
Joined: Mon Apr 07, 2008 7:02 am

Re: buildscripts-20080308 is broken

Post by n8gray » Thu Apr 10, 2008 9:50 am

Just a "me too." If somebody figures out a way around this I'd love to hear about it. :)

WinterMute
Site Admin
Posts: 1478
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: buildscripts-20080308 is broken

Post by WinterMute » Thu Apr 10, 2008 11:27 pm

Wait for updated buildscripts, the patchset in these is wrong, sorry.
Help keep devkitPro toolchains free, Donate today

Personal Blog

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest