Page 1 of 1

[Windows 10] Error when running MSys2

Posted: Fri May 15, 2020 1:21 pm
by nannin
Sorry if this is the wrong place to post -- I think this is an error on my end, not the program, so didn't want to start an issue on git. Also, apologies for being so long -- thought I should add as much info as I can.

I installed devkitPro via the graphical installer for Windows, installing only Minimal System and 3DS Development, but whenever I run MSys2 from the folder in the start menu, I get the error:

/usr/bin/bash: Exit 126.
Failed to run '/usr/bin/bash': Permission denied

I am the only user on this PC and thus have full admin privileges. I tried to adjust permissions on /bin/bash, but apparently Admin isn't privileged to have even read permissions (?) let alone change permissions. I have uninstalled, reinstalled 3 times now and keep getting the same error (alongside some new funky errors about keychains? haha) and the same issue with being unable to change permissions for the file. I cannot successfully update due to the same issue.

So, my next attempt at a fix...
I have separately installed MSYS2 64bit from their website.
I can run MSys2 MSYS just fine, but due to being inexperienced with MySys2, I am unable to follow correctly, even when reading the header Customising Existing Pacman Install because I haven't got sudo (due to being on a Windows machine).

With that context, my questions are:
[*] Is there a known fix for the Permission denied error with the 3.0.3 installer? Should I be trying a different version of the installer?
[*] Are there any tutorials for install on Windows using MSys2 that I just missed?
[*] Am I just making a stupid error somewhere? Am I making this into a bigger task than it is? lol

Thank you so much for taking the time to read my tome. :oops: Any pointers would be greatly appreciated!! :D

Re: [Windows 10] Error when running MSys2

Posted: Thu May 28, 2020 3:33 am
by WinterMute
Could you try this again after uninstalling and deleting any files the installer downloaded. It may be that things went slightly wrong due to an old msys2 bundle. Make sure the devkitPro folder gets removed before trying again.

you can just issue the commands without sudo on msys2, sorry that's not clear.