Missing dependencies for devkitARM?

Post Reply
aviraldg
Posts: 1
Joined: Mon Jan 11, 2021 3:03 pm

Missing dependencies for devkitARM?

Post by aviraldg » Mon Jan 11, 2021 3:13 pm

Hi,

I'm trying to follow the instructions on wiki/devkitPro_pacman to get things set up for 3DS development, on MSYS2 (x86_64.) Trying to install the 3ds-dev group results in the following:

Code: Select all

pacman -S 3ds-dev
:: There are 7 members in group 3ds-dev:
:: Repository dkp-windows
   1) 3dslink  2) 3dstools  3) devkitARM  4) devkitARM-gdb  5) general-tools
   6) picasso  7) tex3ds

Enter a selection (default=all):
warning: 3dslink-0.5.2-2 is up to date -- reinstalling
warning: 3dstools-1.1.5-1 is up to date -- reinstalling
warning: devkitARM-gdb-9.2-4 is up to date -- reinstalling
warning: general-tools-1.2.0-2 is up to date -- reinstalling
warning: picasso-2.7.0-1 is up to date -- reinstalling
warning: tex3ds-2.0.1-2 is up to date -- reinstalling
resolving dependencies...
warning: cannot resolve "devkitarm-rules", a dependency of "devkitARM"
warning: cannot resolve "devkitarm-crtls", a dependency of "devkitARM"
:: The following package cannot be upgraded due to unresolvable dependencies:
      devkitARM
Indeed, searching for these packages using pacman -Ss shows that they are missing. Have I missed something in the setup instructions, or are things broken somehow at the moment?

WinterMute
Site Admin
Posts: 1495
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: Missing dependencies for devkitARM?

Post by WinterMute » Wed Apr 28, 2021 9:24 pm

There are two repositories. One for the libraries and a second for the binaries. You've only added the repository for the binaries.
Help keep devkitPro toolchains free, Donate today

Personal Blog

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest