Updating packages using pacman fails

Post Reply
urmum-69
Posts: 2
Joined: Wed Jul 29, 2020 8:22 pm

Updating packages using pacman fails

Post by urmum-69 » Thu Apr 15, 2021 9:03 pm

Recently, when I update all of my packages using pacman -Syu, all of the devkitpro ones fail with a 404

error: failed retrieving file '3dstools-1.1.5-1-x86_64.pkg.tar.xz' from downloads.devkitpro.org : The requested URL returned error: 404
warning: failed to retrieve some files
...
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, no packages were upgraded.

Here are the relevant lines in /etc/pacman.conf

[multilib]
Include = /etc/pacman.d/mirrorlist

[dkp-libs]
Server = https://downloads.devkitpro.org/packages

[dkp-linux]
Server = https://downloads.devkitpro.org/packages/linux

Any idea why this happens? This used to work fine, and I have not changed the setup at all on my end.

WinterMute
Site Admin
Posts: 1495
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: Updating packages using pacman fails

Post by WinterMute » Tue Apr 27, 2021 12:36 pm

We moved the packages when we started providing aarch64 binaries, you need to add /$arch/ to the repo url now. See wiki/devkitPro_pacman#Customising_Exist ... an_Install
Help keep devkitPro toolchains free, Donate today

Personal Blog

urherenow
Posts: 2
Joined: Sat May 01, 2021 5:02 am

Re: Updating packages using pacman fails

Post by urherenow » Sat May 01, 2021 6:07 am

my dkp-pacman was v1.0.1, and I had to manually download the .deb for 1.0.2 and install it. This fixed my issues. I'm on Ubuntu and have no pacman.conf file.

I'm so glad SciresM updated Atmosphere and said "Atmosphere-libs was updated to use GCC 11 (latest devkitA64/devkitARM releases)." or I wouldn't have a clue until I was out to sea, where I would have no way of updating my laptop.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests