HomebrewMenu with devkitARM 27

support for the ARM toolchain
Post Reply
Quirky
Posts: 19
Joined: Thu Nov 15, 2007 8:45 pm

HomebrewMenu with devkitARM 27

Post by Quirky » Mon Dec 28, 2009 11:51 am

I've been running the homebrew menu program from http://devkitpro.svn.sourceforge.net/sv ... mebrewMenu on my EZ Flash Vi, due to touch screen issues with the manufacturer's loader. I've updated to DKA 27 and svn up'd the homebrew menu and now it doesn't boot any NDS programs.

On the DS, the list of nds files shows. I select the game as before, it shows "Running fat: /any.nds" on the lower screen, but goes no further. Any ideas what could have happened?

Tomdev
Posts: 82
Joined: Thu Jan 08, 2009 9:15 pm

Re: HomebrewMenu with devkitARM 27

Post by Tomdev » Mon Dec 28, 2009 2:11 pm

That's weird. I have an ezvi too and it works (compiled with the last devkitARM and I loaded my homebrew which is also compiled with the last devkitARM).
I tested this on my dslite and my dsi and both were working so I don't know what the problem could be.

StevenH
Posts: 133
Joined: Sun Feb 22, 2009 7:59 pm

Re: HomebrewMenu with devkitARM 27

Post by StevenH » Mon Dec 28, 2009 2:57 pm

I'm the same, I've even replaced the default launcher with the homebrew menu, I've not downloaded the latest version of the menu as it's got a couple of things done to it for the next version, and I'm also attempting to change the look of the application a little. If you want I can provide a zip of the files on my sd card so that you can try them out, they were last updated at the start of December.

WinterMute
Site Admin
Posts: 1403
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: HomebrewMenu with devkitARM 27

Post by WinterMute » Mon Dec 28, 2009 3:10 pm

Did you update libnds and do a clean build of the hbmenu? I've had to do quite a bit of memory map rearranging for DSi related things.
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

Quirky
Posts: 19
Joined: Thu Nov 15, 2007 8:45 pm

Re: HomebrewMenu with devkitARM 27

Post by Quirky » Mon Dec 28, 2009 5:29 pm

Yeah, I updated everything. I'll keep checking. If it works for others in the same situation, it must be my own install that's messed up somewhere.

Quirky
Posts: 19
Joined: Thu Nov 15, 2007 8:45 pm

Re: HomebrewMenu with devkitARM 27

Post by Quirky » Tue Dec 29, 2009 6:45 am

I realised that I had to change VoidFn to VoidFunctionPointer to get bootloader/source/boot.c to compile. So I updated to the latest svn libnds just in case, but still no joy. So that's the released devkitARM 27 with the released libraries, except libnds which is from subversion r3851.

I added a few iprintfs and it does seem to be running through to the swiSoftReset() in nds_loader_arm9.c, but then doesn't actually boot. Adding iprintf("here\n"); at e.g. nds_loader_arm9.c line 280 caused a different response though - instead of just hanging on "Running fat:", the screen blacked out afterwards.

This was on a DSi BTW, but similar no-boot problems with a phat DS and EZ flash V (the previous model to the Vi).

I've tried various DLDI patches too, in case that made any difference. Very odd.

WinterMute
Site Admin
Posts: 1403
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: HomebrewMenu with devkitARM 27

Post by WinterMute » Tue Dec 29, 2009 11:31 pm

Sorry, my fault - I was experimenting with a thumb build which is failing somewhere. I've reverted the boot loader Makefile in SVN.
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

Quirky
Posts: 19
Joined: Thu Nov 15, 2007 8:45 pm

Re: HomebrewMenu with devkitARM 27

Post by Quirky » Wed Dec 30, 2009 10:57 am

Ah, that's got it. Runs fine now with all the latest stuff.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests