REQUIRE: 2007 version of devkitpro (devkitARM)

support for the ARM toolchain
Post Reply
andwan0
Posts: 2
Joined: Thu Jan 21, 2010 10:06 pm

REQUIRE: 2007 version of devkitpro (devkitARM)

Post by andwan0 » Fri Feb 05, 2010 1:24 pm

I am trying to build an old DS open source project (DSZhongwen). I think the last updated source files were dated 2007-08-15. This doesn't compile with latest PALib because PALib has changed so much and made many functions obsolete. So I managed to find a 2007 PALib (plus it's included libnds folder) from https://sourceforge.net/projects/pands/

I've got it to build. But now am getting linking problems. It is:

c:/devkitpro/devkitarm/arm-eabi/lib/ds_arm9_crt0.o: In function `CIDLoop':
(.init+0x2e0): undefined reference to `initSystem'

So I suspect it's the version of devkitpro. Am wondering if anyone has a 2007 version of devkitpro, especially devkitARM. I've tried sourceforge but it looks like any files older than 2008 were already deleted.. or sourceforge project wasn't created until then.

Please please can someone help me find and give me 2007 of devkitpro.

StevenH
Posts: 133
Joined: Sun Feb 22, 2009 7:59 pm

Re: REQUIRE: 2007 version of devkitpro (devkitARM)

Post by StevenH » Fri Feb 05, 2010 6:27 pm

Sorry but there is no way you will ever get a version of devkitPro that old - it's not even supported.

Like PAlib, the devkitPro toolchains has all evolved and the changes to the way the current devkitARM works means that anything from back then will not work without some, possibly major, changes to the entire project - the first of which is to strip PALib out of it and get it working on pure libnds calls...

andwan0
Posts: 2
Joined: Thu Jan 21, 2010 10:06 pm

Re: REQUIRE: 2007 version of devkitpro (devkitARM)

Post by andwan0 » Fri Feb 05, 2010 7:26 pm

StevenH wrote:Sorry but there is no way you will ever get a version of devkitPro that old - it's not even supported.

Like PAlib, the devkitPro toolchains has all evolved and the changes to the way the current devkitARM works means that anything from back then will not work without some, possibly major, changes to the entire project - the first of which is to strip PALib out of it and get it working on pure libnds calls...
Hmm, you can try building it: http://www.rodrigoroman.com/rrc2soft/fi ... 0c.src.zip

Like I said, I managed to build it with latest devkitPro 1.5.0 but with a 2007 PALib. It built alright... just got one linker error

undefined reference to `initSystem' in ds_arm9_crt0.o

which I guess devkitARM has changed... or requires me to create a initSystem()... or PALib to have a initSystem()?



PS
Strip PALib ?? how to do that?

WinterMute
Site Admin
Posts: 1404
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: REQUIRE: 2007 version of devkitpro (devkitARM)

Post by WinterMute » Sun Feb 07, 2010 5:44 am

First thing to do is uninstall your toolchain then reinstall it without ever reinstalling PAlib. You broke the tools by installing PAlib which is precisely why we will not support anyone using that library.

http://wiki.devkitpro.org/index.php/PAlib
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest