Build errors after using latest updater (v3)

support for the ARM toolchain
Post Reply
Diegoisawesome
Posts: 1
Joined: Tue Oct 10, 2017 10:17 am

Build errors after using latest updater (v3)

Post by Diegoisawesome » Tue May 22, 2018 8:06 am

The latest updater that can be found on SourceForge is v2.1.1 but when downloaded it prompts to use 3.0.0 instead. (Attempting to ignore the update does not allow any files to be downloaded). In the process of installing only the GBA development tools, I see some warnings and errors flash by in the MSYS screens (too quickly to read) and when finally installed, things just error out. arm-none-eabi-cpp errors silently (exit code 1); when ran verbosely, it seems to get stuck on cc1, which when ran on its own, simply states that it was unable to find the shared library libwinpthread-1.dll. I have reason to suspect that one of those errors from the installation process was related to this library and unfortunately I don't know how to proceed from here.

WinterMute
Site Admin
Posts: 1403
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: Build errors after using latest updater (v3)

Post by WinterMute » Wed May 23, 2018 10:59 pm

Apologies, some teething trouble with moving over to the pacman based package management.

Pacman doesn't like installing over existing files that it doesn't know about so currently the best way forward is to uninstall the toolchains & reinstall everything with the latest installer.

Please note that uninstalling will remove everything in the devkitPro folder so please make sure that you move anything in there you might want to keep first.
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest