devkitProUpdater-3.0.3 error - folders aren't installed

support for the ARM toolchain
Post Reply
hyper_elastagirl
Posts: 4
Joined: Sun Jul 26, 2020 9:38 pm

devkitProUpdater-3.0.3 error - folders aren't installed

Post by hyper_elastagirl » Sun Jul 26, 2020 10:17 pm

I've been trying to install for windows using the graphical installer linked on the getting started page of the wiki, but every time I try and install it, I get an error where only the msys2 folder and the uninstaller appear in my devkitPro folder.

I made sure I had the gba box checked at the beginning of the installation process. I've tried everything I can think of to fix it- uninstalling, reinstalling, restarting my pc, downloading to the C: and D: drives, nothing has worked. I'm completely stumped and it's driving me crazy.

I even watched several youtube videos to see if I was missing something, and in one the guy had this same error message:

mkdir: cannot change permissions of '/dev/shm': Permission denied
mkdir: cannot change permissions of '/dev/mqueue': Permission denied

All he did to fix it was to redownload and rerun the installer, which didn't work for me.

Any help would be greatly appreciated! I do have ubuntu on my computer because I use it for my uni classes, so I could always try and get it installed on there. I would really prefer to get it running on windows.

WinterMute
Site Admin
Posts: 1473
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: devkitProUpdater-3.0.3 error - folders aren't installed

Post by WinterMute » Mon Jul 27, 2020 1:47 am

Occasionally there are breaking changes in upstream msys2 which unfortunately break the version we install as a base for devkitPro toolchains. I've just updated our version so hopeful this should work for you now.

Make sure you remove the partial install and the msys-2.10.0.7z file if it exists. Running the updater will download a new version.

Let me know if it installs for you now.
Help keep devkitPro toolchains free, Donate today

Personal Blog

hyper_elastagirl
Posts: 4
Joined: Sun Jul 26, 2020 9:38 pm

Re: devkitProUpdater-3.0.3 error - folders aren't installed

Post by hyper_elastagirl » Mon Jul 27, 2020 6:54 pm

Hey, thanks for the quick response! Unfortunately it still won't download properly, it looks like I'm still getting the same errors.

WinterMute
Site Admin
Posts: 1473
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: devkitProUpdater-3.0.3 error - folders aren't installed

Post by WinterMute » Tue Jul 28, 2020 2:41 pm

I tested this yesterday with a fresh install on a windows 7 VM so I'm pretty sure the most recent archive works OK. Are you sure you deleted your local copy of msys-2.10.0.7z? It's a 66769391 byte file with sha256sum of 62f38d5a15c94bfbe0a390c514d64bf780655da6af150440e70f0a06cf3715ba. Did you uninstall the previvious broken attempt? There's an uninst.exe in the devkitPro folder.

I've just verified that the install from a fresh download of the devkitPro Updater is working properly.
Help keep devkitPro toolchains free, Donate today

Personal Blog

hyper_elastagirl
Posts: 4
Joined: Sun Jul 26, 2020 9:38 pm

Re: devkitProUpdater-3.0.3 error - folders aren't installed

Post by hyper_elastagirl » Tue Jul 28, 2020 6:41 pm

Yeah, I made sure to use the uninstaller and delete all files. I actually have a friend who's been helping me try to figure this out, and not only are they having the same errors, but yesterday when they tried to install it again it just installed the msys2 folder, not even the uninstaller.

hyper_elastagirl
Posts: 4
Joined: Sun Jul 26, 2020 9:38 pm

Re: devkitProUpdater-3.0.3 error - folders aren't installed

Post by hyper_elastagirl » Thu Aug 06, 2020 9:44 pm

Hey, just wanted to pop in and say that the problem is resolved! I have no idea what I did to fix it, the only difference between the attempt I made today and the previous ones is that I am on my university's wifi and not my home wifi. Whatever the cause of the issue was it is now resolved.

WinterMute
Site Admin
Posts: 1473
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: devkitProUpdater-3.0.3 error - folders aren't installed

Post by WinterMute » Sat Aug 08, 2020 7:21 pm

Good news. I expect it was just a cache issue somewhere that's been resolved by moving to a different network though.
Help keep devkitPro toolchains free, Donate today

Personal Blog

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests