[SOLVED] fatInitDefault() fails whith self-booting game

Support for the GBA/DS/Gamecube/Wii media card library
Post Reply
Posts: 4
Joined: Tue Jul 14, 2009 10:44 pm

[SOLVED] fatInitDefault() fails whith self-booting game

Post by LeF » Sat Aug 01, 2009 10:18 am


I am trying to make a "self booting card" for the DS.
I mean that I want my game to start like an original game, and not having to select it from a menu.

I am using a genuine DSTT card, and I figured out that renaming a .nds image to TTMENU.DAT will launch it automatically.

However, when my .nds image is launched this way, fatInitDefault() fails (everything works fine when I use the standard launch menu).

I already tried to add the TTMENU.SYS and all support files from the original DSTT's menu (except the original TTMENU.DAT), and it still doesn't work.

Has anyone already tried to (and successfully ;o) ) obtain a bootable .nds with working libfat?

The only idea I have about this failure is that for some reason, the Auto DLDI patch may not work... But since I always used AutoDLDI's cards, I have no idea how to do it "by hand" :o(

Any hint is welcome :)


PS: I am using those versions:
[devkitARM] Version=26
[libnds] Version=1.3.5
[libndsfat] Version=1.0.4
Last edited by LeF on Sat Aug 01, 2009 4:29 pm, edited 1 time in total.

Posts: 4
Joined: Tue Jul 14, 2009 10:44 pm

Re: fatInitDefault() fails whith self-booting game

Post by LeF » Sat Aug 01, 2009 12:04 pm

Once again, writing down the issue bring me the solution :lol:

This was indeed a DLDI issue.

I was mislead by the DSTT official webpage that was telling that "you just have to drag and drop image files on the card, and they will be automatically DLDI patched".
Files are not patched when you copy them to the card, but by the menu application everytime you launch them... (probably after they are loaded in RAM).

There is no official DLDI patch for this card, since it is supposed to be automatic, but the ttio.dldi from Yasu (http://home.usay.jp/pc/etc/nds/) make things work for the "reading" part (it still don't write anything on the SD Card...).

I am still looking for the read/write support...

EDIT: Please don't mind about the writing non-issue... While editing my source code, I pressed without noticing a key that changed the path where I save my stuffs to a nonexistent folder, causing the issue :oops:

What you may remember from this post is : You can use the libfat on a booting image file by patching it with the right DLDI (even if your card has a so-called "DLDI Autopatch" feature).
And if you're having a DSTT card, the YSmenu's ttio.dldi file does it :P

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests