Latest libfat with Max Media player

Support for the GBA/DS/Gamecube/Wii media card library
Post Reply
Quirky
Posts: 19
Joined: Thu Nov 15, 2007 8:45 pm

Latest libfat with Max Media player

Post by Quirky » Wed Jan 06, 2010 6:59 pm

I had these issues reported against bunjalloo "Initalising Fat fails on Max Media Player":
http://code.google.com/p/quirkysoft/iss ... ail?id=121
http://code.google.com/p/quirkysoft/iss ... ail?id=122

Recompiling with devkitARM r26 and the previous libfat release (1.0.4) fixes the problem, but that's not really a good solution long term.

Has anyone else run into any problems running the latest libfat on the Max Media player?

WinterMute
Site Admin
Posts: 1403
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: Latest libfat with Max Media player

Post by WinterMute » Wed Jan 06, 2010 8:00 pm

Someone recently reported that FAT media initialised with linux wasn't working but worked fine when formatted by windows. It may be related to some extra checks for a FAT filesystem that were added in the latest code, not sure yet. Unfortunately I haven't yet been able to reproduce it locally.

Kind of surprised that people are using MMD tbh.
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

je.sid
Posts: 4
Joined: Thu Jun 11, 2009 10:35 pm

Re: Latest libfat with Max Media player

Post by je.sid » Thu Apr 29, 2010 10:52 am

Hi
I have experienced the same problem. r26 + libfat-1.0.4 works fine (unfortunately I lost the r26 toolchain). r30 + libfat-1.0.4 works also fine but much slower. r30 + libfat >= 1.0.5 (including the latest svn version) always reposts an initialization error.

My Hardware: GBA + Supercard SD

Greetinx
Sid

SifJar
Posts: 1
Joined: Mon Jun 14, 2010 7:58 pm

Re: Latest libfat with Max Media player

Post by SifJar » Mon Jun 14, 2010 8:02 pm

I have the same issue with my Max Media Dock, with a Windows-formatted CF card. I tried to run HBMenu and the BootStrap (both DLDI patched) and FAT Init always failed. I have also read that other slot 2 cards have had problems over at GBAdev.org.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests