Editing .bashrc doesn't work.

Posts that don't fit in the other forums
Post Reply
MASTER260
Posts: 2
Joined: Sun May 04, 2014 4:18 am

Editing .bashrc doesn't work.

Post by MASTER260 » Sun May 04, 2014 4:32 am

Hey, so, I tried adding the following to my .bashrc file:

Code: Select all

export DEVKITPRO=/home/jonathan/devkitPro
export DEVKITARM=${DEVKITPRO}/devkitARM
export DEVKITPPC=${DEVKITPRO}/devkitPPC
The problem is, when I try to compile stuff, I still get these errors:

Code: Select all

Makefile:7: *** "Please set DEVKITARM in your environment. export DEVKITARM=<path to>devkitARM.  Stop.
Makefile:7: *** "Please set DEVKITPPC in your environment. export DEVKITPPC=<path to>devkitPPC".  Stop.
Here's the .bashrc file in case it helps: https://docs.google.com/file/d/0B1jrUd0 ... FQUmc/edit

I feel like I did something stupid. What did I do wrong?

Thanks,
M260

WinterMute
Site Admin
Posts: 1403
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: Editing .bashrc doesn't work.

Post by WinterMute » Mon May 05, 2014 10:42 am

Do you have a ~/.profile? What's in there if you do?
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

MASTER260
Posts: 2
Joined: Sun May 04, 2014 4:18 am

Re: Editing .bashrc doesn't work.

Post by MASTER260 » Tue May 06, 2014 9:01 pm

WinterMute wrote:Do you have a ~/.profile? What's in there if you do?

Code: Select all

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
	. "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests