Page 1 of 1

Can't install on ubuntu?

Posted: Sat Jul 25, 2020 12:12 am
by mEnTL32
Trying to install on ubuntu 14.04.4, I get as far as:

Code: Select all

[email protected]:/raid/mentl32$ sudo dpkg -i ./devkitpro-pacman.amd64.deb
[sudo] password for mentl32:
(Reading database ... 899465 files and directories currently installed.)
Preparing to unpack ./devkitpro-pacman.amd64.deb ...
Unpacking devkitpro-pacman (1.0.2) over (1.0.2) ...
dpkg: dependency problems prevent configuration of devkitpro-pacman:
 devkitpro-pacman depends on gpg; however:
  Package gpg is not installed.
 devkitpro-pacman depends on pkg-config; however:
  Package pkg-config is not installed.
 devkitpro-pacman depends on libssl1.1; however:
  Package libssl1.1 is not installed.
A couple of those are not installable. I think gpg is well and truly dead. I've tried to install a couple different ways but these three packages are always missing.

I asked here since I'm actually just trying to build an old GBA homebrew I found. I've got most of what I need but the original author seemed to use devkitARM for one of his libs.

Re: Can't install on ubuntu?

Posted: Sat Jul 25, 2020 4:41 am
by WinterMute
Ubuntu 14.04 reached end of life in April 2019. We don't support installation on that distro, sorry.

https://www.omgubuntu.co.uk/2019/04/ubu ... nd-of-life

You could try apt-get install -f but you should really upgrade to a newer ubuntu. 16.04 should work but latest LTS is 20.04

Re: Can't install on ubuntu?

Posted: Sat Jul 25, 2020 9:09 am
by mEnTL32
Yeah I really should. Are you saying that gpg would install if I updated?

Re: Can't install on ubuntu?

Posted: Sun Jul 26, 2020 12:38 am
by WinterMute
I don't really understand why gpg wouldn't install on your system now so I can't really guarantee that upgrading would fix it. We're not really equipped for providing extensive linux distro support though.

I'm reasonably sure that the binaries we ship won't run on 14.04 though even if you do satisfy the dependencies for pacman. Personally I'd recommend making backups and then installing a newer ubuntu fresh rather than upgrading and potentially taking issues with you. I'm currently running 20.04 on test machines for x86_64 and aarch64 linux.

Re: Can't install on ubuntu?

Posted: Mon Jul 27, 2020 2:12 am
by WinterMute
I'm now reliably informed that gpg wasn't available until bionic (18.04) so currently 16.04 won't work either. This is what I mean by not equipped for extensive linux distro support.

18.04 should work. 20.04 has been tested.

I can adjust the dependencies on the .deb for 16.04 but I'm reasonably sure that our pacman build won't run on 14.04.

Re: Can't install on ubuntu?

Posted: Mon Jul 27, 2020 9:29 am
by mEnTL32
Ah well there you go! Thanks!

Still tinkering with this project, and I've got more problems than missing devkitarm. Original developer used a tool I can't find

Code: Select all

XMCONVERT:=../../xmply/xmconvert
It's operating on a few xm files he has.. looks like game music.. but can't find anything else. I know it gets turned into a .s file but that's about it. No args into the tool make me think it was probably something he wrote but didn't include. Stuck until I figure out what this is.

Re: Can't install on ubuntu?

Posted: Wed Jul 29, 2020 11:00 pm
by WinterMute
It might be worth looking at converting it to use maxmod instead if that's feasible. See https://maxmod.devkitpro.org/

mmutil & maxmod are available via pacman.