Doom64 DS

mtheall
Posts: 210
Joined: Thu Feb 03, 2011 10:47 pm

Re: Doom64 DS

Post by mtheall » Sat May 12, 2012 2:50 am

My source/output files' md5sums are
  • b67748b64a2cc7efd2f3ad4504561e0e
    c778e4eec3d608383fbc9f401c8fd43b
Do these match your input/output?

Kaiser
Posts: 38
Joined: Wed Apr 25, 2012 4:44 am

Re: Doom64 DS

Post by Kaiser » Sat May 12, 2012 3:23 am

Not sure about source but the MD5 checksum for the IWAD on my end is BB9AF686446D3831FB50A3DC089E1B71

mtheall
Posts: 210
Joined: Thu Feb 03, 2011 10:47 pm

Re: Doom64 DS

Post by mtheall » Sat May 12, 2012 3:54 am

Maybe if I can build the Windows version of wadgen. I can't build due to missing "sdl_config.h". What dependencies to do I need to cover?

mtheall
Posts: 210
Joined: Thu Feb 03, 2011 10:47 pm

Re: Doom64 DS

Post by mtheall » Sat May 12, 2012 4:22 am

Okay I got the SDL stuff and that's not a problem anymore. Problem is now I get

Code: Select all

.\WadGen.rc(10) : fatal error RC1015: cannot open include file 'afxres.h'.
Any ideas? I just can't get it working at all. Maybe if you can provide a pre-built wadgen?

Kaiser
Posts: 38
Joined: Wed Apr 25, 2012 4:44 am

Re: Doom64 DS

Post by Kaiser » Sat May 12, 2012 5:07 am

SDL is the only dependency. I have no idea why it's looking for afxres.h

elhobbs
Posts: 355
Joined: Thu Jul 02, 2009 1:19 pm

Re: Doom64 DS

Post by elhobbs » Sat May 12, 2012 10:52 am

I do not think the ds wadgen uses sdl at all. I commented out the sdl header file reference. Afxres.h is not available in vs express. I think I commented that out too. Then there was a problem finding resource.h which I did not fix properly. The file exists so I just pasted the contents replacing the include reference.

mtheall
Posts: 210
Joined: Thu Feb 03, 2011 10:47 pm

Re: Doom64 DS

Post by mtheall » Sat May 12, 2012 8:02 pm

I removed all references of afxres.h but it still gives the same error. I'm using VC++ 2008 Express.

WinterMute
Site Admin
Posts: 1436
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: Doom64 DS

Post by WinterMute » Sat May 12, 2012 9:38 pm

Kaiser wrote:Tried both waiting for the right VCOUNT value as well as setting REG_VCOUNT to 192 for each 64k of data I dma to the VRAM. Still got flickering unfortunately but at this point now, I can live with just 256kb of data to work with.
You can't set it to 192, you can only write values from 202 to 212 inclusive while the register is still within that range. It's intended for syncing multiplayer games so they're on the same frame. Maybe you can work out a size to DMA that completes within that range & reset vcount as you go?
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

mtheall
Posts: 210
Joined: Thu Feb 03, 2011 10:47 pm

Re: Doom64 DS

Post by mtheall » Sat May 12, 2012 10:20 pm

Okay now I have a WAD which matches your checksum. But I still get exactly the same errors. Are you compiling with the latest devkitARM/libnds?

Edit: I updated doom via svn and now I get to

Code: Select all

Loading level...
Used memory: 563 kb
Used static memory: 73 kb
Used cached memory: 156 kb
Used level memory: 331 kb
Staging Area
and then it appears to hang. The PC is at FF000008 so it appears to have jumped to a junk address.

Kaiser
Posts: 38
Joined: Wed Apr 25, 2012 4:44 am

Re: Doom64 DS

Post by Kaiser » Sat May 12, 2012 11:01 pm

mtheall wrote:Okay now I have a WAD which matches your checksum. But I still get exactly the same errors. Are you compiling with the latest devkitARM/libnds?

Edit: I updated doom via svn and now I get to

Code: Select all

Loading level...
Used memory: 563 kb
Used static memory: 73 kb
Used cached memory: 156 kb
Used level memory: 331 kb
Staging Area
and then it appears to hang. The PC is at FF000008 so it appears to have jumped to a junk address.
More likely this is related to me using an older version of the SDK. I am still at 1.5.0. I'll need to update and fix whatever is not working with the latest version. IMO I kinda find this annoying.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 7 guests