Gamecube Samples run at 50 FPS on Dolphin

Post Reply
DLDrago
Posts: 1
Joined: Wed Oct 16, 2019 3:37 pm

Gamecube Samples run at 50 FPS on Dolphin

Post by DLDrago » Wed Oct 16, 2019 3:39 pm

I'm trying to get the graphics examples in the GameCube section to run at 60 fps, but they seem to only run at 50 fps. I'm using the latest Dolphin emu. Can anyone help me?

DacoTaco
Posts: 10
Joined: Tue Sep 22, 2009 5:37 pm

Re: Gamecube Samples run at 50 FPS on Dolphin

Post by DacoTaco » Sun Apr 12, 2020 3:02 pm

there could be few things going on here i believe.
could you go into the dolphin settings and enable PAL60 ( its under wii settings ) , maybe it has influence on the video mode for gamecube stuff too.

i'd also suggest looking into what video mode was detected, this can be checked by looking at what the value of rmode->viTVMode is in the code after it has initialised the video.

values are defined as following :

Code: Select all

#define VI_NTSC                     0		/*!< Video standard used in North America and Japan */
#define VI_PAL                      1		/*!< Video standard used in Europe */
#define VI_MPAL                     2		/*!< Video standard, similar to NTSC, used in Brazil */
#define VI_DEBUG                    3		/*!< Video standard, for debugging purpose, used in North America and Japan. Special decoder needed */
#define VI_DEBUG_PAL                4		/*!< Video standard, for debugging purpose, used in Europe. Special decoder needed */
#define VI_EURGB60                  5		/*!< RGB 60Hz, 480 lines mode (same timing and aspect ratio as NTSC) used in Europe */
some of these are 50hz, and not 60

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests