nitroFS / libFAT and DSi not working properly

Support for the GBA/DS/Gamecube/Wii media card library
Post Reply
Posts: 20
Joined: Thu Jun 09, 2011 11:56 am

nitroFS / libFAT and DSi not working properly

Post by Mysoft » Tue Dec 14, 2021 12:32 am

so i finally could try my DSi with exploits... with unLaunch + twilight...
but then i found out that none of my .nds files that used either libFat or NitroFS worked there... independent of the mode of operation... directly from unLaunch... from twilight in DS/DSi modes... direct and indirect using bootstrap nothing...

so i upgraded my toolchain to latest one... since i tought i would probabily need some more extra checks on libNDS to be extra compatible...
and so i tried the sample codes ... nitrodir and libfatdir... but the results were very bad...

first now libfatdir does not work on desmume anymore (with the ... while the samples from the previous tool that used the slot2-MPCF)
then on the DSi things improved a bit... i could get libfat working using bootstrap + NDS mode... but only that way
and nitroFS were hanging under the same settings...

if i change settings to DSi mode... then nitroFS works... but it lists the SD card files not the virtual nitro FS O_o ... and on all other modes the sample hangs...

so theres a way to have what i had before? that i could use both NitroFS and LibFat... without all those nuances... what should i do?

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests