> libfat-1.0.4 issues

Support for the GBA/DS/Gamecube/Wii media card library
Post Reply
Posts: 4
Joined: Thu Jun 11, 2009 10:35 pm

> libfat-1.0.4 issues

Post by je.sid » Thu Apr 29, 2010 9:02 am


it's me again. Somehow libfat doesn't like me...

About a year after I finished my last GBA project I wanted to change some small parts of the code. Therefore I updated the toolchain. devkitARM from r26 to r30 and among others also latfat from 1.0.4 to 1.0.7. I didn't change the source code, yet. But however the initialization of FAT fails. I do not know why. All versions above of 1.0.4 of libfat fail. I even tried the svn stuff (1.0.8). Only with libfat-1.0.4 all seems to work find...

Has anything changed that I miss? My hardware is a GBA and a Supercard SD.

Another thing that I observed:
devkitARM r30 + libfat-1.0.4 is much slower than devkitARM r26 + libfat-1.0.4
The sources compiled with r26 needed about 2sec to load a picture. The same code and picture takes about 7sec to load if the sources are compiled with devkitARM r30.
And, of course, I don't have the source of r26 anymore... :|

Can anybody tell me what I am doing wrong...

Site Admin
Posts: 1528
Joined: Tue Aug 09, 2005 3:21 am
Location: UK

Re: > libfat-1.0.4 issues

Post by WinterMute » Fri Apr 30, 2010 5:44 pm

How did you format your SD card in the first place?

My supercard miniSD works fine with the latest tools but one person reported an init failure with a card formatted using linux - everything worked fine for him after he reformatted using Windows. I'm still unable to reproduce the failure unfortunately.

What might help is a raw image of your SD card.
Help keep devkitPro toolchains free, Donate today

Personal Blog

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest