libnds 1.5.0, default arm7 0.5.20

Latest devkitPro news and announcements
Post Reply
WinterMute
Site Admin
Posts: 1367
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

libnds 1.5.0, default arm7 0.5.20

Post by WinterMute » Mon Feb 14, 2011 1:11 pm

libnds 1.5.0 and default arm7 0.5.20 are now available through the windows installer as usual and from the getting started page on the wiki.

libnds 1.5.0
  • i2c interrupt handler now libnds internal, arm7 code uses callback for powerbutton.
  • getBatteryLevel now works on DSi, bit 7 is set when charging, DSi levels from 0 - 15, DS returns 15 for fully charged, 3 for low.
  • sdmmc delays adjusted to improve speed.
  • swiDecompressLZSSVram now works in DSi mode.
  • added DiscoStew's dynamic texture allocation, see http://devkitpro.org/viewtopic.php?f=25&t=2028.

default arm7 0.5.20
  • recompiled with latest libnds.
nds examples 20110214
  • updated for changes in latest libnds.
  • some bugs fixed in examples
  • Paletted Cube example updated to use new dynamic textures
With thanks to blasty, zeromus, yellows8 and DiscoStew for their contributions to these releases.
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

MisterFuzzy
Posts: 4
Joined: Sat Feb 12, 2011 6:35 am

Re: libnds 1.5.0, default arm7 0.5.20

Post by MisterFuzzy » Fri Mar 04, 2011 11:01 pm

Awesome Sauce. :D

ian1999
Posts: 1
Joined: Sun Jan 30, 2011 9:15 am

Re: libnds 1.5.0, default arm7 0.5.20

Post by ian1999 » Mon Mar 28, 2011 10:53 am

(Newbie @ homebrew dev): I have used the Windows installer. It appears that default.arm7 (or default.elf) is not included in the .nds image automatically. When I compile the devkitPro examples, the touch panel and some buttons are not working. All the ARM9 stuff is working OK though. I have linux dev. experience. When checking the supplied Makefiles, I cannot find any rules for linking in default.elf into the nds image. I have tried to change the rule that executes ndstool to include the default.elf file, but that does not seem to do anything. What am I missing here?

WinterMute
Site Admin
Posts: 1367
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: libnds 1.5.0, default arm7 0.5.20

Post by WinterMute » Wed Mar 30, 2011 10:24 am

The default arm7 code is included in the nds file automatically, if it wasn't then nothing would work at all.

If you're running on an an emulator then it's possible that things aren't being emulated correctly. The latest desmume (0.9.7) and no$gba both work as expected but I'm not sure about the other emulators.

If you're running on hardware then the launcher menu on your card may be interfering with homebrew code, try using hbmenu if you can.
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

lazyprogramer
Posts: 85
Joined: Mon Sep 27, 2010 5:26 pm

Re: libnds 1.5.0, default arm7 0.5.20

Post by lazyprogramer » Sun Apr 10, 2011 2:48 pm

I installed the installer and all my projects were removed!!!!! :shock:
Is there any possibility to get my files back?!!

User avatar
Izhido
Posts: 107
Joined: Fri Oct 19, 2007 10:57 pm
Location: Costa Rica
Contact:

Re: libnds 1.5.0, default arm7 0.5.20

Post by Izhido » Mon Apr 11, 2011 7:01 pm

Um... were your projects, by any chance, inside the root devkitPro folder?

If so, then: 1) They´re gone for good, and 2) It was your own fault.

It's been said A LOT of times... do NOT place your own projects in the devkitPro installation folders.

Hope you had some backup, or a git/svn repo recently updated. If not, hope you learned an important lesson.

lazyprogramer
Posts: 85
Joined: Mon Sep 27, 2010 5:26 pm

Re: libnds 1.5.0, default arm7 0.5.20

Post by lazyprogramer » Tue Apr 12, 2011 3:16 pm

It is a lesson for me :(
I only have some parts of my project but I have a bit older version of code saved! :)
I hope I can rebuild the Makefile...

xXDracheXx
Posts: 6
Joined: Tue Mar 29, 2011 5:28 am

Re: libnds 1.5.0, default arm7 0.5.20

Post by xXDracheXx » Wed May 04, 2011 5:24 am

lazyprogramer wrote:It is a lesson for me :(
I only have some parts of my project but I have a bit older version of code saved! :)
I hope I can rebuild the Makefile...
How do you rebuild the Makefile...?
MHDS, Yeah!

WinterMute
Site Admin
Posts: 1367
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: libnds 1.5.0, default arm7 0.5.20

Post by WinterMute » Wed May 04, 2011 11:09 am

He means recreate, as in write it again from scratch.
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

lazyprogramer
Posts: 85
Joined: Mon Sep 27, 2010 5:26 pm

Re: libnds 1.5.0, default arm7 0.5.20

Post by lazyprogramer » Wed May 04, 2011 2:09 pm

Code: Select all

How do you rebuild the Makefile...?
I chose a Makefile from one of the nds examples and added
some rules for the .pcx , .grit, ... files and I added the
libs I used for my project! Recreating the Makefile was
not hard work, but it's annoying!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest