View unanswered posts | View active topics It is currently Fri Dec 14, 2018 10:29 am



Reply to topic  [ 4 posts ] 
 [devkitPPC/portlibs] Build issues 
Author Message

Joined: Wed Nov 07, 2018 12:32 am
Posts: 2
Currently, when trying to build ppc portlibs from pacman-packages, some PKGBUILDs fail:

- bzip2 1.0.6
The link to package source code's is dead (there are still some mirrors for the source code such as https://fossies.org/linux/misc/bzip2-1.0.6.tar.gz)

- mpg123 1.25.10
autoconf fails due to some error with LT_SYS_MODULE_EXT. Commenting out LT_SYS_MODULE_EXT seems to fix the issue (https://raw.githubusercontent.com/wiiu- ... 5.10.patch) but idk if that's the optimal solution


Wed Nov 07, 2018 12:46 am
Profile
Site Admin

Joined: Tue Aug 09, 2005 3:21 am
Posts: 1301
Location: UK
rw-r-r-0644 wrote:
Currently, when trying to build ppc portlibs from pacman-packages, some PKGBUILDs fail:


Ideally you're not supposed to build anything from pacman-packages, you're supposed to install them with wiki/devkitPro_pacman

Quote:
- bzip2 1.0.6
The link to package source code's is dead (there are still some mirrors for the source code such as https://fossies.org/linux/misc/bzip2-1.0.6.tar.gz)


There's a patch pending to use debian's copy, not currently sure of the best approach but, again, the binary is available via (dkp-)pacman & it would be appreciated if people used it instead of trying to compile things. Fossies looks like it might be a good mirror to use though, thanks for pointing it out.

Quote:
- mpg123 1.25.10
autoconf fails due to some error with LT_SYS_MODULE_EXT. Commenting out LT_SYS_MODULE_EXT seems to fix the issue (https://raw.githubusercontent.com/wiiu- ... 5.10.patch) but idk if that's the optimal solution


The optimal solution is to install the binary via (dkp-)pacman though.

It's hard to know what the issue is without seeing the actual output. Chances are you're missing some pre-requisite for building - libtool at a guess.

Ideally we want to encourage people to be using the binary packages rather than building everything from source. It helps to standardise everyone's environment & improve the chances of a given project compiling on another developer's setup. Ultimately if people are using the binaries we provide rather than compiling their own then we can eliminate a huge number of potential issues when asked for support.

_________________
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog


Fri Nov 09, 2018 4:27 pm
Profile ICQ WWW

Joined: Wed Nov 07, 2018 12:32 am
Posts: 2
Thanks for the quick reply :)

WinterMute wrote:
Ideally you're not supposed to build anything from pacman-packages, you're supposed to install them with wiki/devkitPro_pacman


Yeah, I undertand that's not the correct way of installing the libraries and I'm actually using dkp-pacman for managing the libraries. I only tried to build the repo out of curiosity and thought of reporting back these issues in case it helps with the repo/build.

WinterMute wrote:
The optimal solution is to install the binary via (dkp-)pacman though.

It's hard to know what the issue is without seeing the actual output. Chances are you're missing some pre-requisite for building - libtool at a guess.


Thanks for the hint, I was actually missing libtool.

A minor issues it that when first running makepkg, the checksum verification for mpg123-1.25.10.patch fails. I've downloaded the file many times to make sure my download wasn't corrupted, but it seems the hash in the PKGBUILD is actually wrong.
By fixing that out, it build correctly.

BTW, on a different matter, the mpg123 (1.25.10-1) package provided on dkp-pacman seems to be broken. The library seems to have been build with x86_64 as target instead of PPC, as can be verified by running:
Code:
$ pacman -S ppc-mpg123
[...]
$ cd /opt/devkitpro/portlibs/ppc/lib
$ readelf -h libmpg123.a | grep 'Class\|File\|Machine'
File: libmpg123.a(parse.o)
  Class:                             ELF64
  Machine:                           Advanced Micro Devices X86-64
File: libmpg123.a(frame.o)
  Class:                             ELF64
  Machine:                           Advanced Micro Devices X86-64
[...]
$ readelf -h libout123.a | grep 'Class\|File\|Machine'
File: libout123.a(libout123.o)
  Class:                             ELF64
  Machine:                           Advanced Micro Devices X86-64
File: libout123.a(stringlists.o)
  Class:                             ELF64
  Machine:                           Advanced Micro Devices X86-64
[...]


Tue Nov 13, 2018 12:09 am
Profile
Site Admin

Joined: Tue Aug 09, 2005 3:21 am
Posts: 1301
Location: UK
rw-r-r-0644 wrote:

Yeah, I undertand that's not the correct way of installing the libraries and I'm actually using dkp-pacman for managing the libraries. I only tried to build the repo out of curiosity and thought of reporting back these issues in case it helps with the repo/build.


Sure, it's appreciated, I just worry a bit when people start fiddling with toolchain installs. Bug reports & fixes are always welcome though.

Quote:
A minor issues it that when first running makepkg, the checksum verification for mpg123-1.25.10.patch fails. I've downloaded the file many times to make sure my download wasn't corrupted, but it seems the hash in the PKGBUILD is actually wrong.
By fixing that out, it build correctly.

BTW, on a different matter, the mpg123 (1.25.10-1) package provided on dkp-pacman seems to be broken. The library seems to have been build with x86_64 as target instead of PPC, as can be verified by running:


Whoops, sorry.

Unfortunately the compile falls back to native tools if it can't find the cross tools & sometimes I don't notice. The patch was updated for one of the other toolchains & I didn't go back & fix the hash for ppc.

Fixed both these issues now & released a new package. Also added devkitPPC to the makedepends list so it hopefully shouldn't happen in future.

_________________
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog


Wed Nov 14, 2018 1:26 am
Profile ICQ WWW
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
  Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.
Get devkitPro at SourceForge.net. Fast, secure and Free Open Source software downloads