configure: error: Missing POSIX Threads support

Post Reply
tytan652
Posts: 1
Joined: Mon Jan 20, 2020 10:46 pm

configure: error: Missing POSIX Threads support

Post by tytan652 » Mon Jan 20, 2020 10:59 pm

Hi, I'm trying to compile avahi libraries for the Switch and when I use ./configure.
I get this:

Code: Select all

checking for the pthreads library -lpthreads... no
...
configure: error: Missing POSIX Threads support
And when I execute this command:

Code: Select all

/opt/devkitpro/devkitA64/aarch64-none-elf/bin/ld -L/opt/devkitpro/portlibs/switch/lib -lpthread
I get this:

Code: Select all

/opt/devkitpro/devkitA64/aarch64-none-elf/bin/ld: warning: cannot find entry symbol _start; not setting start address
Anyone know what I can do about this?
Thank you in advance

./configure command:

Code: Select all

./configure \
    CFLAGS='-D__SWITCH__ -D_GNU_SOURCE -O2 -march=armv8-a -mtune=cortex-a57 -mtp=soft -fPIC -ftls-model=local-exec' \
    CXXFLAGS='-D__SWITCH__ -D_GNU_SOURCE -O2 -march=armv8-a -mtune=cortex-a57 -mtp=soft -fPIC -ftls-model=local-exec' \
    LDFLAGS='-fPIE -L/opt/devkitpro/portlibs/switch/lib -L/opt/devkitpro/libnx/lib' \
    --prefix=/opt/devkitpro/portlibs/switch \
    --host=aarch64-none-elf \
    --enable-shared=no \
    --disable-glib \
    --disable-gobject \
    --disable-dbus \
    --disable-gdbm \
    --disable-libdaemon \
    --disable-python --disable-pygobject --disable-python-dbus \
    --disable-mono \
    --disable-autoipd \
    --disable-monodoc \
    --disable-doxygen-doc --disable-doxygen-dot --disable-doxygen-xml --disable-doxygen-html \
    --disable-manpages \
    --disable-xmltoman \
    --disable-qt4 \
    --disable-qt5 \
    --disable-gtk \
    --disable-gtk3 \
    --with-xml=none

WinterMute
Site Admin
Posts: 1452
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: configure: error: Missing POSIX Threads support

Post by WinterMute » Sat Apr 11, 2020 5:31 pm

It's impossible to know what's going on without seeing why the pthreads check fails. The relevant output should be in config.log. Nothing immediately jumps out in what you've posted except maybe --enable-shared=no which I think should normally be handled by --disable-shared --enable-static
Help keep devkitPro toolchains free, Donate today

Personal Blog

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests