Page 1 of 1

devkitA64 alpha 7

Posted: Wed Feb 21, 2018 11:50 pm
by WinterMute
We're finally at a point where I feel comfortable adding the latest of our toolchains to the installer along with libnx and some switch examples.

These releases are available though Automated Installer/Updater as usual. Use the exe for windows, the perl scripts for other platforms.

Downloading should hopefully be easier and faster now. We were prompted to update the installer to pull from github during the recent Sourceforge downtime. The site has served us well over the years but I think it's time for us to move on due to the ongoing unreliability.

For those of you new to devkitPro toolchains there's a brief elevator guide at ... nvironment to get started building code. Instructions for running code on your 3.0.0 Switch are at

Come join us in #switchdev on efnet for lots of switch dev fun.

Regrettably Smartscreen may try to dissuade you from running the installer since my code signing certificate expired and I can no longer sign the binary. Unfortunately, rather than the €20 it cost me last year for an Open Source cert I now need to purchase a cryptographic card and reader to get it renewed so it'll be some €150 instead which is a little beyond my means atm. I would be incredibly grateful if those of you who appreciate the tools and libraries would consider making a donation towards getting the cert renewed. Once the card & reader are purchased further renewals would be a much more manageable €28. The donation page is at

Many thanks for your consideration.

[UPDATE] Thanks to Myria we raised enough to purchase new certificate and the cryptocard & reader. However don't let that stop you showing your appreciation for the tools by makinga donation ;o)

Re: devkitA64 alpha 7

Posted: Fri Mar 02, 2018 2:11 pm
by maxrudek
Hi, I know I'm new here and getting started. I tried all of the installers since 1.5.3 to 2.1.0. Few hours spent on searching.
This is what I get(it's nothing new I guess?) :

Create folder: c:\devkitPro\libmirko
untgz::extract -d 'c:\devkitPro\libmirko' -zbz2 'D:\Download\Maksym\Setups\libmirko-0.9.7.tar.bz2'
gzread: incomplete block read
Error: Failure reading from tarball.
failed to extract libmirko-0.9.7.tar.bz2: Error: Failure reading from tarball.

I tried to: delete all .bz2 files(advice found on this forum somewhere), reboot windows, switch off antivirus, do not install in folders with spaces etc.
If I'm not allowed to post here, I'm sorry.

Re: devkitA64 alpha 7

Posted: Tue Mar 20, 2018 9:43 pm
by WinterMute
I've just tried this with latest installed and it seems fine. Are you still experiencing problems?

Sometimes the download servers take too long & you end up with corrupted files. Usually everything is fine again when people try later.