Networking example (sockettest) not working

Post Reply
random
Posts: 3
Joined: Tue Dec 27, 2016 9:23 pm

Networking example (sockettest) not working

Post by random » Tue Dec 27, 2016 9:46 pm

Hi there !
I'm really new to homebrew and was then trying some of the examples.
So I tried the network example sockettest, it compiled well so I put the dol on a SD card and loaded it with swiss.
It loaded successfully but froze on "configuring network...". I'm sure my BBA is working because I already tried loading homebrew using the PSO exploit and I'm able to connect to the swiss HTML page (at least with version r377).
Is that a bug in the example, libogc or am I just too stupid to do things correctly ? :oops:

Thank you very much in advance for any answer.

random
Posts: 3
Joined: Tue Dec 27, 2016 9:23 pm

Re: Networking example (sockettest) not working

Post by random » Thu Dec 29, 2016 2:36 pm

Actually, it works when supplying ip configuration, only DHCP doesn't work.
Any ideas ?

WinterMute
Site Admin
Posts: 1360
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: Networking example (sockettest) not working

Post by WinterMute » Thu Jan 05, 2017 3:43 pm

Sorry to take so long replying - had to dig out my cube & bba to test things.

After rebuilding libogc with -O2 instead of -Os the DHCP definitely works now. Bear in mind that it does take a bit of time to obtain an IP address - it's about 10 seconds or so for me (which feels a lot longer)
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

random
Posts: 3
Joined: Tue Dec 27, 2016 9:23 pm

Re: Networking example (sockettest) not working

Post by random » Sun Jan 08, 2017 7:06 pm

Thank you very much sir!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests