Compile error: cannot find -lmm

Post Reply
retro gloss bit
Posts: 1
Joined: Sat Jul 01, 2017 8:35 am

Compile error: cannot find -lmm

Post by retro gloss bit » Sat Jul 01, 2017 9:23 am

Hi all~
I'm new and interested in GBA dev.
I'm walking along with the tutorial by tonc.
When I compile the template example project there is a error saying cannot find -lmm, the output like this:

Code: Select all

$ make
template.c
arm-none-eabi-gcc -MMD -MP -MF /opt/devkitpro/examples/gba/template/build/template.d -g -Wall -O3 -mcpu=arm7tdmi -mtune=arm7tdmi -fomit-frame-pointer -ffast-math -mthumb -mthumb-interwork -iquote /opt/devkitpro/examples/gba/template/include -I/opt/devkitpro/libgba/include -I/opt/devkitpro/examples/gba/template/build -c /opt/devkitpro/examples/gba/template/source/template.c -o template.o 
linking cartridge
/opt/devkitpro/devkitARM/lib/gcc/arm-none-eabi/6.3.0/../../../../arm-none-eabi/bin/ld: cannot find -lmm
collect2: error: ld returned 1 exit status
/opt/devkitpro/devkitARM/gba_rules:24: recipe for target '/opt/devkitpro/examples/gba/template/template.elf' failed
make[1]: *** [/opt/devkitpro/examples/gba/template/template.elf] Error 1
Makefile:119: recipe for target 'build' failed
make: *** [build] Error 2
I'm working on Ubuntu 16.04 64bit system.
Any ideas on this error? Thanks!

WinterMute
Site Admin
Posts: 1338
Joined: Tue Aug 09, 2005 3:21 am
Location: UK
Contact:

Re: Compile error: cannot find -lmm

Post by WinterMute » Fri Jul 07, 2017 12:16 pm

I'd presume you didn't install maxmod.

devkitARMupdate.pl from https://sourceforge.net/projects/devkit ... Installer/ should install it for you.
Help keep devkitPro toolchains free, Donate today

devkitPro IRC support
Personal Blog

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests